Indiana University
University Information Technology Services
  
What are archived documents?
Login>>
Login

Login is for authorized groups (e.g., UITS, OVPIT, and TCC) that need access to specialized Knowledge Base documents. Otherwise, simply use the Knowledge Base without logging in.

Close

ARCHIVED: In a web browser, how do I speed up purging the cache?

When you access a web page in a browser such as Internet Explorer, Firefox, or Netscape, the browser caches it. When you return to the same page later, the browser can retrieve it from cache rather than downloading it from the network again. This makes for much faster web browsing, especially when you return to the same page often. However, the cache on the hard disk periodically needs to be cleaned out, which can take some time. Browsers typically clear the cache progressively, while running. You can also empty the cache yourself (see How do I clear my web browser's cache, cookies, and history?).

Decreasing the size of the cache will reduce the amount of time required to clear it. However, the cache will have to be cleared more often, since there will be less space for the browser to store cached files. You could reduce the cache to zero, but previously viewed pages would then need to be downloaded again at each repeat visit. The best size for your cache depends on your browsing habits. If you routinely visit only a few pages, a small cache will do, but if you routinely visit a lot of pages, keep a larger cache.

To find the cache size setting of various browsers, follow the appropriate instructions below:

Firefox

  • Firefox 2.0 for Windows: From the Tools menu, select Options... . Click Advanced, and then click the Network tab. Under "Cache", enter your preferred cache size in the text box.

  • Firefox 2.0 for Mac OS X: From the Firefox menu, select Preferences... . Click Advanced, and then click the Network tab. Under "Cache", enter your preferred cache size in the text box.

  • Firefox 1.x for Windows: From the Tools menu, select Options... . Under "Cache", enter your preferred cache size in the text box. (If you don't see the text box, click the + (plus sign) next to "Cache".) Click OK.

  • Firefox 1.x for Mac OS X: From the Firefox menu, select Preferences... . Under "Cache", enter your preferred cache size in the text box. (If you don't see the text box, click the triangle next to "Cache".) Click OK.

Netscape

  • Netscape Browser 8 for Windows: From the Tools menu, select Options... . Click Privacy, and then click the + (plus sign) next to "Cache".

  • Netscape 7 for Mac OS X: From the Netscape menu, select Preferences... . From the list on the left side of the window, click the triangle next to Advanced, and then select Cache.

  • Netscape Navigator 4.x, 6.x, and 7.x: From the Edit menu, select Preferences... . Click Advanced, and then click Cache.

  • Netscape Navigator 2.x and 3.x: From the Options menu, choose Network Preferences. Select the Cache tab.

  • Netscape Navigator 1.1 and 1.2: From the Options menu, choose Preferences. Select the Cache and Network tab.

Microsoft Internet Explorer

  • Internet Explorer 5.x and 6.x (Windows): From the Tools menu, select Internet Options... . Under the General tab, under "Temporary Internet files", click Settings... .

  • Internet Explorer 5.x (Mac OS X): From the Explorer menu, select Preferences... . Under Web Browser, click Advanced.

    Note: Microsoft is no longer developing or distributing Internet Explorer for the Macintosh. UITS strongly recommends that you use a different browser, such as Safari or Firefox.

  • Internet Explorer 4.x and 5.x (Mac OS): From the Edit menu, select Preferences... . Under Web Browser, click Advanced.

  • Internet Explorer 4.x (Windows): From the View menu, select Internet Options. Under the General page tab, in "Temporary Internet Files", click Settings.

  • Internet Explorer 3.0: From the Edit menu, select Preferences. Click the Advanced tab.
This is document abts in domain all.
Last modified on November 01, 2008.

I need help with a computing problem

  • Fill out this form to submit your issue to the UITS Support Center.
  • Please note that you must be affiliated with Indiana University to receive support.
  • All fields are required.



Please provide your IU email address. If you currently have a problem receiving email at your IU account, enter an alternate email address.

I have a comment for the Knowledge Base

  • Fill out this form to submit your comment to the IU Knowledge Base.
  • If you are affiliated with Indiana University and need help with a computing problem, please use the I need help with a computing problem section above, or contact your campus Support Center.