ARCHIVED: How do I set up Netscape 3.x-4.x and Internet Explorer 5.x to open telnet links?

This content has been archived, and is no longer maintained by Indiana University. Information here may no longer be accurate, and links may no longer be available or reliable.

To set up your web browser so that you can link to telnet links, follow the appropriate steps below for the browser you use:

Netscape Navigator 4.x

You must tell Netscape Navigator which telnet application you use. The procedure varies depending on your platform and the version of Navigator you are using:

Mac OS

  1. From the Edit menu, select Preferences....
  2. Underneath "Navigator:", select Applications.
  3. From the list of applications, select Netscape/Telnet, and click the Edit... button.
  4. Select the Application radio button, and then click Choose....
  5. Locate the telnet program you want to use and select it. In most cases, you should choose BetterTelnet.

    Note: UITS no longer supports NCSA Telnet and recommends that you do not leave it as your default telnet setting.

  6. After you have selected the telnet program, from the "File Type:" pull-down menu, select CONF.

    Note: If you cannot select CONF, go back to the Choose... button and select any non-telnet application. Then click the Choose... button again and select a telnet application. You should be able to select CONF now.

  7. To save your changes and close the dialog boxes, click OK, then click OK again.

Windows

  1. From the Edit menu, select Preferences....
  2. Under the Navigator category, select Applications.
  3. In the list of applications, select URL:Telnet Protocol.
  4. Click Edit..., and in the "Application:" field, enter the path of your telnet application.

Netscape Navigator 3.x or earlier

Mac OS

  1. From the Options menu, select General Preferences.
  2. Click the Applications tab.
  3. Click the Browse... button and locate your telnet application. Highlight it and click Open.

Windows

  1. From the Options menu, select Preferences (General Preferences in Netscape Navigator 2.0 or earlier).
  2. Select the Apps tab.
  3. In the "Telnet Application" box, type the path of the telnet application you use.

If you do not already know the correct path, here are the paths for some common telnet clients, assuming that they have been installed in their default directories:

  • For the Hummingbird Host Explorer telnet client:
      c:\program files\iucom32\hostex\programs\tnvt.exe
  • For the LAN WorkPlace telnet client:
      c:\lwp\bin\presentr.exe /profile default.php /host
  • For the PPP version of the LAN WorkPlace telnet client:
      c:\net\bin\presentr.exe /profile default.php /host
  • For the built-in Windows 95 telnet client:
      c:\windows\telnet.exe

Internet Explorer

Mac OS

  1. To update your telnet preferences, from the Edit menu, choose Preferences....
  2. Highlight Protocol Helpers.
  3. Under "Protocol Helper Settings", scroll down until you you see telnet.
  4. Double-click telnet. In the dialog box that appears, click the Change Helper... button (Choose Helper... in Internet Explorer 5).

    Note: UITS no longer supports NCSA Telnet and recommends that you do not keep NCSA Telnet as your default telnet setting.

  5. From your computer's hard drive, choose the name of the telnet program you want as your default. Click OK, then click OK again.

Windows

Internet Explorer for Windows handles telnet preferences in a very different way from other Internet browsers. Internet Explorer doesn't let you set preferences from within the program. Instead, it works with the Windows operating system.

Note: The process of changing Windows telnet preferences is extremely complex and should be attempted only by experienced users. If you do not set your preferences correctly, you can disable Windows' inherent telnet ability and possibly damage your operating system.

Note: You should know the correct path to get to your operating system's telnet preferences before you attempt to change telnet settings; otherwise, your telnet preferences won't work correctly.

  1. From the Windows desktop, double-click My Computer.
  2. Since Internet Explorer changes the general Windows interface, this step varies according to which version of Internet Explorer you have installed:
    • If you use Internet Explorer 5.5, from the Tools menu, select Internet Options.
    • If you use Internet Explorer 5.0, from the View menu, choose Options or Folder Options.... (For Internet Explorer 5.0 in Windows 2000, choose Tools, then Folder Options....)

  3. In the window that appears, choose the File Types tab.
  4. Scroll down the list of registered file types and select URL:Telnet Protocol.
  5. Click Open, and then Edit....

    Note: Depending on the version of Internet Explorer that you have, you may need to click Edit... and then Edit... again.

  6. The Edit window will allow you to type the path to the telnet program you wish to use. When you are finished, click OK to close the windows.

This is document afqh in the Knowledge Base.
Last modified on 2018-01-18 10:06:28.

Contact us

For help or to comment, email the UITS Support Center.