ARCHIVED: In Microsoft Office, how can I customize menu bar, toolbar, or Ribbon items?

This content has been archived, and is no longer maintained by Indiana University. Information here may no longer be accurate, and links may no longer be available or reliable.

Note: You cannot customize the menus or toolbars in Entourage.

On this page:


Office for Windows

Office 2010 and 2007 feature the Quick Access Toolbar and the Ribbon. The default location of the Quick Access Toolbar is in the upper-left corner of the window, to the right of the program icon. It contains icons for actions within the program, which remain the same regardless of which tab is visible on the Ribbon.

The Ribbon is a set of menus and tools that spans the top of Office 2010 and 2007 programs. It replaced the menus (e.g., File, Edit, View) that were available in earlier versions of Office. The Ribbon groups commands previously found in menus or toolbars into collections based on activities.

Customizing the Quick Access Toolbar

You can display the Quick Access Toolbar in the upper-left corner of the program or below the Ribbon. To move the Quick Access Toolbar, click the down arrow to the right of the Quick Access Toolbar and choose Show Below the Ribbon or Show Above the Ribbon. Alternatively, you can right-click any blank space in the Quick Access Toolbar or Ribbon, click Customize Quick Access Toolbar..., and then check or uncheck Show Quick Access Toolbar below the Ribbon.

To add and remove commands from the Quick Access Toolbar:

  1. Right-click the Quick Access Toolbar or Ribbon and select Customize Quick Access Toolbar.... In Office 2007, make sure the drop-down menu under "Customize Quick Access Toolbar:" is set to For all documents (default).
  2. Select commands you wish to add from the column on the left and click the Add >> button to move them to the Quick Access Toolbar.

Note: You can also add commands by locating the desired command on the Ribbon, right-clicking the command, and choosing Add to Quick Access Toolbar.

Back to top

Customizing the Ribbon

  1. In Office 2010, click the File tab, then Options, and then, from the menu on the left, click Customize Ribbons.

    In Office 2007, click the Microsoft Office Button, then Word Options, and then, from the menu on the left, click Customize.

  2. Under "Choose commands from:", use the drop-down menu to specify the group of commands you want to browse. Under "Customize the Ribbon:", use the drop-down menu to specify the tabs you want to customize.
  3. Use the Add >> and << Remove buttons to add and remove commands from the Ribbon. You can also choose New Tab.

Back to top

Customizing Office for Mac OS X

Customizing an existing menu or toolbar

  1. In Office 2011, from the View menu, select Toolbars and then Customize Toolbars and Menus.... In Office 2008, from the View menu, select Customize Toolbars and Menus....
  2. To remove an item, click and drag it out of its menu or toolbar.
  3. If you want to add an item to a toolbar or menu, in the customize window, click the Commands tab. Under "Categories:", click the category that best describes the item you want to add. To the right, a listing of items within that category will appear. Click the item you wish to add, and drag it into the toolbar or menu where you wish to place it.
  4. Click OK. The item is now added to the toolbar or menu.

Back to top

Adding a new menu

  1. In Office 2011, from the View menu, select Toolbars and then Customize Toolbars and Menus.... In Office 2008, from the View menu, select Customize Toolbars and Menus....
  2. Click the Toolbars and Menus tab and check Menu Bar. This will produce a toolbar that looks like the menu bar at the top of the screen.
  3. Click the Commands tab. Under "Categories:", click New Menu. In the window to the right, click the new menu and drag it to the position in the Menu Bar toolbar where you want it to appear.
  4. Right-click or Ctrl-click the new menu bar item and, from the contextual menu, select Properties.... Apply a name to your new menu.
  5. Now you can add items to your new menu. In the customize window, click the Commands tab, and then click the category that best describes the item that you want to add. In the window to the right, click and drag the item into the small box below your new menu. Repeat this process for all items you wish to add to your menu. When you are finished adding items, click OK. Your new menu will now appear at the top of the screen, and you will be able to select the items within it to use.

Back to top

This is document ajcm in the Knowledge Base.
Last modified on 2018-01-18 13:09:15.

Contact us

For help or to comment, email the UITS Support Center.