ARCHIVED: How can I remove hidden information from Microsoft Word, Excel, and PowerPoint documents?

This content has been archived, and is no longer maintained by Indiana University. Information here may no longer be accurate, and links may no longer be available or reliable.

Microsoft Word, Excel, and PowerPoint documents contain a variety of hidden information, including names, email addresses, deleted text, revision marking, and locations of related files on your computer. While some of the data is needed by collaboration features such as Track Changes, Comments, and Send for Review, other information you may not intend to share may be viewable by anyone with access to the document.

On this page:


Office settings controlling hidden data

Whether these types of data are stored in your document depends largely (but not entirely) on settings in your Office applications. Office applications can keep track of revisions made by everyone who modifies a document with the Track Changes feature. To enable this, from the Review tab (2010) or the Tools menu (2007), select Track Changes. As the file is modified, any changed or deleted text is automatically added to the file, along with the name of the user who made the edit. To view the tracked changes, in Office 2010 applications, look for your options on the Review tab. In earlier versions, from the View menu, select Markup.

Back to top

Document Inspector in Office 2010 and 2007

Word, Excel, and PowerPoint 2010 and 2007 use the Document Inspector tool to search for and remove both personal data and tracked changes to a document. To use the Document Inspector:

  1. Open an Office document to inspect for hidden data or personal information.
  2. From the File tab (2010) or the Office Button menu (2007), select Save As. To save a copy of your original document, enter a name in the "File name" field.

    Note: It's a good idea to use the Document Inspector on a copy of your original document, because it's not always possible to restore the data that the Document Inspector removes.

  3. In your original document, in 2010, from the File tab, click Info, then Check for Issues, and then Inspect Document. In 2007, from the Office Button menu, select Prepare, and then click Inspect Document.
  4. In the Document Inspector dialog box, check the boxes to choose the types of hidden content that you want to inspect. For more about the individual Inspectors, see Remove hidden data and personal information from Office documents.
  5. Click Inspect. Review the results of the inspection in the Document Inspector dialog box. Click Remove All next to the inspection results for the types of hidden content that you want to remove from your document.

    Note: If you remove hidden content from your document, you might not be able to restore it by clicking Undo.

Back to top

Removing hidden data in previous versions of Office

Note: This option is only available if you edit a document in Office 2007 which was originally created using Track Changes in a previous version of Office.

  1. Open the document containing the hidden data you wish to remove.
  2. From the Tools menu, select Options.
  3. Select the Security tab in the window that appears.
  4. Check Remove personal information from this file on save.

Back to top

Removing hidden data that cannot be removed by any Office setting

For Microsoft Outlook, to remove hidden data that cannot be removed by any Office setting, you can download add-ins that ensure that all Office documents sent as email attachments are cleansed of potentially sensitive information:

  • Workshare is available for a 14-day free trial download.
  • iScrub is sold on a per-license basis.

Back to top

Significant portions of this document were originally adapted from the article "Revealing Codes" by David A. Karp, which appeared in PC Magazine, June 8, 2004.

This is document aooo in the Knowledge Base.
Last modified on 2018-01-18 13:55:39.

Contact us

For help or to comment, email the UITS Support Center.