ARCHIVED: What are the minimum system requirements for using the IU Podcast Portal?

This content has been archived, and is no longer maintained by Indiana University. Resources linked from this page may no longer be available or reliable.
Note:
UITS is working on retiring the Podcast Portal. On Friday, March 16, 2018, https://podcast.iu.edu will point to Kaltura. Content has been migrated from the old portal to Kaltura. Content subscribers will need to re-subscribe to the RSS feed due to the changed podcast URLs as a result of this migration.

UITS recommends the following minimum system requirements when using the Indiana University Podcast Portal:

  • Broadband Internet connection
  • Supported browsers:
    Note:
    Safari 3 for Mac and PC is currently not supported. This browser has displayed unstable behavior when editing podcast information, and UITS recommends not using it for editing podcasts.
  • Audio speakers or headphones; required for listening to podcasts
  • Podcatcher (e.g., iTunes); required for subscribing to podcasts

    iTunes is available free from Apple's Download iTunes page, or via IUware for IU students, faculty, and staff.

  • Portable media player; required for portable listening or watching (e.g., iPod, or another media player that supports MP3 and MP4)

This is document avrr in the Knowledge Base.
Last modified on 2018-03-16 13:02:13.

Contact us

For help or to comment, email the UITS Support Center.