Research Desktop (RED) usage policies and interface features

Following are instructions for using Research Desktop (RED) once you are already connected.

On this page:


Usage policies

Fair share policy

RED nodes are login nodes. You should run parallel or compute-intensive applications on Carbonate's compute nodes.

Everyone who logs into RED shares dedicated nodes that are part of the Carbonate high-performance computing cluster. Because high loads on shared nodes can negatively impact system usability, be aware of how your processes use the system; see Analyzing memory and CPU consumption below.

IU uses a fair share policy that throttles processes and slows down applications for users who are consuming a high percentage of CPU resources; running highly parallel applications can lead to high CPU consumption. Although running such an application for a few minutes for testing purposes is fine, running it for hours can negatively impact the usability of RED for everyone on the node.

If you are going to use highly parallel applications on RED, do one of the following:

  • Limit the parallelism the applications use to 5 or fewer.
  • Run the applications via a normal batch job. You can do this in various ways, including an interactive batch job that allows for graphical output:
    qsub -I -X -q interactive -l ...
  • Only run such applications for short periods of time.

Users who don't follow these policies and fail to respond to requests to change how they use the system may have their jobs halted and lose their login privileges.

Connection policies

ThinLinc Client lets you disconnect your RED session without terminating it; this suspends any currently open applications and keeps your session running on the server.

Note:
Disconnecting is not the same as logging out, which closes open applications, terminates your session on the server, and closes the remote desktop window.

Disconnected sessions are terminated after seven days of inactivity.

Only one RED session is allowed per user. When you connect, if you have no disconnected sessions running, ThinLinc Client automatically creates a new session. If you do have an existing session, you are automatically reconnected to that session. However, if you want a new session rather than your existing one, select End existing session before connecting; the existing session will be terminated and a new one created.

Monthly maintenance window

The scheduled monthly maintenance window for IU's high-performance computing systems is the second Sunday of each month, 7am-7pm.

IU recommends saving your work and logging out before 7am on maintenance days. All sessions still open at 7am on maintenance day will be terminated.

Features

Desktop icons

When you connect to RED, the following icons appear by default on the remote desktop:

Research Desktop (RED) icons

  • Disconnect ThinLinc Session: Double-click to close RED without terminating your remote session. This allows you to reconnect to the same session at a later time.
  • Log Out: Double-click to close RED and terminate your remote session. (For more, see the Logging out versus disconnecting your session section of Download, install, and configure ThinLinc Client to use Research Desktop (RED) at IU.)
  • Firefox: Double-click to open the Firefox web browser.
  • Trash: Delete items by dragging and dropping them to Trash.
    Note:
    Items placed in Trash will continue to count toward your research computing storage quota until you permanently delete them (unless the items are from your Data Capacitor II scratch space). To view items in Trash, double-click Trash. To permanently delete all items, click Empty Trash, and then click Empty Trash again to confirm; to delete an individual item, right-click (or Ctrl-click) the item, select Delete Permanently, and then click Delete to confirm.
  • Home: Double-click to access to your Carbonate home directory. (When you're logged in, the Home icon's label will include your IU username.)
  • HPC EveryWhere: Double-click to access the alpha version of HPC EveryWhere, a portal for accessing high-performance computing tools (Wait-time Visualizer, Script Generator, and HPC Pathfinder) and monitoring IU research supercomputers.
  • DC2 Scratch: Double-click to access your scratch directory on the Data Capacitor II high-throughput file system.
  • Other HPC Systems: Double-click to access options for accessing your account on another IU supercomputer. Use the folder icons to access your home directory space on Big Red II and/or Karst; use the terminal icons to access the login nodes on Big Red and/or Karst.
  • File Browser: Double-click to open the RED file browser, which provides tools and menus for accessing and managing your files, folders, and your desktop.
  • Feedback and Questions: Double-click to open a window that will let you send feedback and questions to the Research Desktop team.
  • Terminal: Double-click to open a terminal window that logs you in automatically on the same node that is serving your RED session.
  • Interactive Job: Double-click to open an interactive session on one of Carbonate's compute nodes. This opens a terminal window and automatically submits an interactive job request for one hour of wall time on four cores of a single compute node. These jobs are routed to an interactive queue and normally should start within two or three minutes. When your job is ready, you will be placed at the compute node's command prompt (you should see something similar to this):
      qsub: waiting for job 143252.s1 to start
      qsub: job 143252.s1 ready
    
      gcc version 6.3.0 loaded.
      Intel compiler suite version 17.0.3 loaded.
      Python programming language version 2.7.13 loaded.
      Perl programming language version 5.24.1 loaded.
      IU-Quota version 1.0 loaded.
      [username@c71 ~]$
    
    Note:
    The Interactive Job shortcut is intended as a convenient way to log into a Carbonate compute node. If your job does not start after two or three minutes, or if you need help using this tool, contact the RED development team.
  • Carbonate Job Manager: Double-click to monitor and manage your jobs running on Carbonate. This opens a "PBS Tools GUI" window for selecting TORQUE (PBS) operations (Job progress monitor, View job output, Submit an interactive job, and Delete job):

    RED PBS tools GUI

  • thindrives: Double-click to access drives and directories on (or connected to) your personal computer.
    Note:
    To enable thindrives access to drives and directories on your personal computer, before connecting to a new session you must configure the ThinLinc Client's "Export Local Resources" option.
  • RED Documentation: Double-click to access RED support documentation.

The RED pop-up lets you change your screen size settings, toggle full-screen view on and off, and access other connection settings during your RED session:

RED pop-up menu

To access the pop-up menu, press F8. (Depending on your local system, you may need to press Fn-F8 or Win-F8.)

To map the pop-up menu to another key:

  • Before opening a session: In the ThinLinc Client login window, click Options to open the "ThinLinc Client Options" window. On the Options tab, under "Session Options", make sure Send system keys is selected, use the Popup menu key selector to assign another key, and then click OK to return to the login window.
  • During your session: Open the pop-up menu, click Options, and then, on the Options tab, make sure Send system keys is selected. Use the Popup menu key selector to assign another key, and then click OK.

To disable the pop-up menu, do the same as above, but set the Popup menu key selector to None.

At the top of the screen, you can use the RED menu bar to launch installed applications, access local and remote resources, and set personal preferences.

  • Click Applications to browse and run installed software in several categories:
    • Analytics: Jupyter Notebook, MATLAB, Mathematica, SAS, SAS Setup, Stata, RStudio
    • GIS: GRASS, QBrowser, QGIS
    • Performance analysis: Allinea Forge, TotalView, Vampir, DDD
    • Storage: Box setup, Scholarly Data Archive; see Access your storage accounts
    • Utilities: Emacs, File Browser, MySQL-Workbench, Screenshot, Spreadsheets, System Monitor, Terminal, Text Editor, VS Code, Wireshark
    • Visualization: Chimera, Cytoscape, FSL View, FSLeyes, Integrative Genomics Viewer, meshlab, paraview
    • IU HPC Slack Channel: Opens a Firefox browser tab to the IU HPC Slack Channel where the IU HPC user community can chat and communicate with one another and Research Technologies staff.
  • Click Places to access local and remote folders, browse bookmarked and local network locations, search for files, or connect to remote computers or shared disks.
  • Click System to access the Preferences menu, which includes several options for changing the appearance and behavior of your desktop.

To customize your desktop, right-click (Windows) or Ctrl-click (Mac) on any part of the desktop or menu bar.

Note:
Some keyboard shortcuts used in the RED interface may differ slightly from the ones on your local computer and may vary from application to application. For example, to copy text, some applications use Shift-Ctrl-c, while others use Ctrl-c. Check the application's Edit menu to see which shortcuts it uses.

Access your storage accounts

From the Applications > Storage menu, you can create a desktop shortcut to your IU Box or access your Scholarly Data Archive accounts through FileZilla.

Box

  1. From the RED menu bar, select Applications > Storage > Box setup. A Box page prompting you to log in will display in Firefox.

    Box login screen

  2. Enter your IU email address and passphrase, and then click Authorize. If prompted, log in with your IU username and passphrase. A page will display the following:

    With access to your Box account, RED_rclone_connect can:

    • Read and write all files and folders stored in Box
  3. Click Grant access to Box. A "Success!" page should open and confirm that you have successfully authorized Box on the Research Desktop. Close the browser window to return to the desktop.
  4. A "Box Launcher" window will report that you have successfully mounted Box.

    Box Launcher success window

    Click OK. The Box shortcut icon should now be on your desktop.

    Your Box directory is unmounted when you log out of RED. The next time you log in and select Box setup, your Box directory should mount without needing re-authorization.

Scholarly Data Archive

You will need an account on the Scholarly Data Archive (SDA) to access it from RED. To do so:

  1. From the RED menu bar, select Applications > Storage > Scholarly Data Archive. This will connect you automatically to your SDA account. This opens FileZilla, connecting automatically to your SDA account.
  2. When prompted, enter your IU passphrase to access the Scholarly Data Archive.

Appearance customization

To customize the appearance of the RED interface, use the Appearance Preferences utility:

  1. From the RED menu bar, select System > Preferences > Look and Feel > Appearance:

    Access 'Preferences' options from 'Systems' menu in Research Desktop (RED)

  2. In the "Appearance Preferences" window, use the Theme, Background, Fonts, and Interface tabs to configure a personalized look and feel for the RED interface.
    Note:
    The available pre-set window and folder themes can be modified by selecting Customize, allowing you to specify your own color scheme, window appearance, icon appearance, icon style, and more.

Analyze memory and CPU consumption

To view current system status data, use the System Monitor utility:

  1. From the RED menu bar, select Applications > Utilities > System Monitor.
  2. To view memory and CPU consumption for your processes and applications, select the Processes tab. By default, only your processes are displayed; to see processes besides your own, in the top right, click the menu icon (next to the search icon), and then select Active Processes or All Processes:

    Running processes viewed in Research Desktop (RED) System Monitor

  3. To add or remove information fields, in the top left, click System Monitor, and then select Preferences; in the "System Monitor Preferences" window, under "Information Fields", use the checkboxes to select the fields to display:

    Research Desktop (RED) 'System Monitor Preferences' window

Supported languages

  • Brazilian Portuguese (pt_BR)
  • English (en_US)
  • Dutch (nl_NL)
  • French (fr_FR)
  • German (de_DE)
  • Italian (it_IT)
  • Russian (ru_RU)
  • Spanish (es_ES)
  • Swedish (sv_SE)
  • Turkish (tr_TR)

If your computer is set to one of these languages, ThinLinc Client will configure itself automatically to use that language.

Note:
If your computer's operating system is set to an unsupported language, ThinLinc Client may not function properly.

To change your keyboard layout, inside your RED session:

  1. From the RED menu bars, select System > Preferences > Hardware > Keyboard.
  2. In the "Keyboard Preferences" window, on the Layouts tab, click Add.
  3. In the "Choose a Layout" window, on the By country or By language tab, use the drop-down lists to select a keyboard variant by country or language, and then click Add.

If your computer's operating system is set to a language that is not supported, ThinLinc Client may not function properly.

Get help

If you have a question or need help with RED, contact the RED development team.

Support for IU research computing systems, software, and services is provided by the Research Technologies division of UITS. To ask a question or get help, contact UITS Research Technologies.

This is document apxv in the Knowledge Base.
Last modified on 2019-03-12 07:20:03.

Contact us

For help or to comment, email the UITS Support Center.